
Introduction to  
Adobe Acrobat Professional 
version X  

 
 

 
   

Office of Information Technology 
West Virginia University 
 

OIT Help Desk: oithelp@mail.wvu.edu, (304) 293-4444  
oit.wvu.edu/training/classmat/acr/ 
 

This workshop will teach you how to create and enhance Portable Document 
Format (PDF) files using Adobe Acrobat software.  
 
Acrobat PDF files are often used as an alternative to HTML to display content 
and forms on the web. Publishers use PDF files as page proofs for authors 

 

Copyright 2012 West Virginia University 



2  WVU Office of Information Technology 

Table of Contents 
Course Description ____________________________________________________________ 3 

Adobe Acrobat in the Real World ________________________________________________ 4 

Adobe Acrobat Software Components _________________________________________________ 4 

Why create PDF documents?_________________________________________________________ 4 

Examples of PDF files used at West Virginia University ____________________________________ 5 

Different ways to create a PDF file _______________________________________________ 6 

Print to the Adobe PDF Printer Driver __________________________________________________ 7 

Using PDFMaker Macro with MS Word 2010 ____________________________________________ 9 

Import an image file ________________________________________________________________ 9 

Enhance a PDF file ___________________________________________________________ 10 

Adobe Acrobat Panels and Menu _______________________________________________ 11 

Adobe Reader Tools __________________________________________________________ 14 

Bookmarks _________________________________________________________________ 15 

Adding Bookmarks ________________________________________________________________ 15 

Editing Bookmarks ________________________________________________________________ 15 

Changing Text Attributes ___________________________________________________________ 16 

Change Text Content ______________________________________________________________ 16 

Hyperlinks __________________________________________________________________ 17 

Modifying Document Pages ____________________________________________________ 18 

Insert Pages _____________________________________________________________________ 18 

Delete Pages _____________________________________________________________________ 18 

Renumber Pages _________________________________________________________________ 18 

Rotate Pages ____________________________________________________________________ 19 

Crop Pages ______________________________________________________________________ 19 

Preferences _________________________________________________________________ 20 

Edit  Preferences _______________________________________________________________ 20 

File  Properties _________________________________________________________________ 21 

Initial View tab ___________________________________________________________________ 21 

Security tab _____________________________________________________________________ 22 

Ways to Learn More about Acrobat _____________________________________________ 23 



Intro to Acrobat 3 

Course Description 

Introduction to Adobe Acrobat  
Learn to use Adobe Acrobat software to create and enhance PDF files.  
Topics:  

• create a PDF file 
o print to Adobe PDF printer driver 
o use PDFMaker Macro 
o import images 
o web capture 

• use navigation tools  
• add and edit bookmarks 
• use the TouchUp Text tool 
• add hyperlinks to internal document pages, external files, and online resources 
• set preferences and document properties 
• resources to learn more about the software 

Prerequisite: basic word processing skills  

Intermediate Adobe Acrobat  
Enhance your PDF files with graphics and media.  
Learn to use annotation tools and the full-text index feature.  

Adobe Acrobat Forms 
How to create forms and use the Form tools in Adobe Acrobat Professional. How to 
create simple calculations for form text fields. How to save and reuse data from a 
completed form. How to validate and format the data entry at the client-side will also be 
covered. Prerequisite: Introduction to Adobe Acrobat  or ETDs at WVU. 

Creating Accessible PDF Files 
How to determine if a PDF file is accessible. How to ensure that PDF files you create, 
especially those from Microsoft Office documents, are accessible to all. How to use the 
Read Out Loud feature in Adobe Reader. 

Adobe Acrobat Workshop Web Page 
oit.wvu.edu/training/classmat/acr/ 
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Adobe Acrobat in the Real World 

Adobe Acrobat Software Components 
Adobe Reader  

freely distributed from adobe.com, read and print PDF files 

Acrobat Standard 
 read, print, combine, annotate, and enhance PDF files 

Acrobat Professional 
same as Standard plus create and edit forms  

Acrobat Distiller 
convert PostScript files to PDF files 

Acrobat Paper Capture 
convert scanned files to PDF  

Acrobat Web Capture 
create a PDF version of a web site or collection of web pages. 

Acrobat Catalog 
create a full-text index of a PDF collection  

Why create PDF documents? 
• A PDF file will look the same on other computers and print the same on printers other 

than the one that was used by the author.  

• Those who are reading the document do not have to have the original software used to 
create the file; they just need a copy of Adobe Reader.  

• Adobe Acrobat PDF files are cross platform; people who are using Macintosh, Windows, 
or Unix computers can all view and print the same PDF files.  

• Often, a PDF file can be smaller than the original document used to create it. 

• Risk of virus transmission is much smaller when using PDF for document exchange via 
email as opposed to Microsoft Office files. 

• You can embed links to multimedia such as sound files and movie clips; color pictures 
can be easily and cheaply included. 

• If you complete a PDF form created by someone else, you can save the form for future 
use. You can export data from a saved form and import data to a new form. 

• With the Professional version of Acrobat, you can create your own forms that look like 
the originals; when opened in Adobe Reader, the user can complete the form and print it 
out - it will then appear as if the person used a typewriter.  
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Pre-Press 
Adobe Acrobat PDF documents are useful for those who send off their brochures, newsletters, 
journal articles, etc., to be printed by a professional printing company or a publisher. The printer 
can send you back a PDF version of what the item will look like when it is published; this 
method is often faster and more accurate than paper drafts or page proofs. Some printers 
accept PDF files as the source material for their printing. 

Collaborative Writing  
PDF files are a useful way to jointly edit a document. The files can be easily shared via email 
attachments or from a web server. Acrobat tools such as sticky notes, highlighter, and pencil 
can be used to add comments or call attention to items that need correction. All collaborators 
who want to mark up the PDF file must have a copy of the Adobe Acrobat software. 

Sharing information on the Internet  
PDF files are often smaller than Word, PowerPoint, or WordPerfect files which will reduce 
download time. Any images on the pages are embedded in that single file so several files don't 
have to be transferred from the web server to the web browser. You don't have to have the 
original software application to open the file or any special viewer other than the Adobe Reader; 
you are also protected from macro viruses that are sometimes embedded in Microsoft Office 
documents. Using the Adobe Acrobat Hyperlink tool, you can add hyperlinks to other pages in 
the document or to Internet URLs and email addresses. You can protect a PDF file from editing 
or copying. 

Examples of PDF files used at West Virginia University 
• Admissions Forms for prospective students to print and complete 

[http://adm.wvu.edu/home/downloadable_forms] 
• Electronic Information Document Repository [http://wvuscholar.wvu.edu/] 

o ETD Collection: theses and dissertations at WVU  
o Honors Theses 
o Hosted conference proceedings & white papers submitted by WVU faculty 

• Extension Service publications [http://www.wvu.edu/~exten/infores/pubs.htm] 
• Plant Pathology Research Articles 

[http://www.caf.wvu.edu/kearneysville/biggs/pubform.html] 
• OIT Workshop Handouts [http://oit.wvu.edu/training/classmat/ ] 
• Online Forms: 

o Extended Learning Forms: 
[http://online.wvu.edu/continuing/forms/] 

o Software License Information Center (SLIC) Order Form 
[http://oit.wvu.edu/slic/files/orderform.pdf] 

• Faculty Syllabi – an instructor often posts a course syllabus as a PDF file 
• University Libraries – interlibrary loan, where allowed 

o Electronic Reserves [http://ereserves.lib.wvu.edu/] 
• WVU Course Catalogs [http://coursecatalog.wvu.edu/] 
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Different ways to create a PDF file 
Following are some of the many ways to create a PDF file:  

• Print to PDF.  Your source document is converted to a PostScript file, and 
Acrobat Distiller converts the PostScript file to PDF. Current versions of Acrobat 
do this conversion for you behind the scenes. 

• Use the Acrobat PDFMaker macro in conjunction with Microsoft Office software.  
Note that for Microsoft Office documents, Print to PDF does not include some of 
the features available in PDFMaker, such as bookmarks and hypertext links.  

• Start in Acrobat and use the File > Create PDF command. 

• Web Capture a web site using Adobe Acrobat 5.0 or higher. 

• Export to PDF from other Adobe applications such InDesign or Photoshop. 

• Scan document directly into a PDF file from Acrobat software. This file will be 
“graphic images”, not full searchable text, unless you subsequently use Acrobat's 
OCR Text Recognition command. Scanning must be done at 600dpi for optical 
character recognition of scanned text. 

• Scan document into a an image file and import the image file into Acrobat. 
Create Adobe PDF Online Service: free trial (5 files) or by subscription 
($10/month).  Visit createpdf.adobe.com for more information. 

• If you are using Office 2007 (Word, Excel, PowerPoint), you can download a free 
add-on (SaveAsPDFandXPS.exe) from microsoft.com, which allows you to save 
Office files as PDF without owning Adobe Acrobat software. Office 2010 has this 
add-on included (you don’t have to download and install it).  

• If you are using a Macintosh running OS X, you can print files to PDF using the 
Save as PDF button on the Print dialog. You cannot edit the PDF file without 
Adobe Acrobat software. 

• You can convert a LaTeX file to PDF using Ghostscript and other tools. LaTeX is 
used on campus by engineering, physics, chemistry, math, and computer 
science students. 

• If you are using OpenOffice software, use the File > Export to PDF command. 

• You can obtain and use free or lower cost software such as CutePDF, PDF 
Master, or gDoc Creator to create a PDF file. 

Today’s workshop will focus on converting a Word document to PDF using the “Print to 
PDF” method and the PDFMaker Macro for Office 2010. We will also create a PDF file 
from a PowerPoint file and from a web page. If time permits, we will also cover 
converting an image to PDF. 
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Print to the Adobe PDF Printer Driver 
In several applications, you can use the Adobe PDF printer to convert your file to a PDF. 

1. Create, edit, and save your document.  
2. Most software: Select File from the menu and choose Print.  

Office 2007: Click on the Office Button then click on Print. 
Office 2010: Click on the File tab and choose Print 

3. Select Adobe PDF as your printer. 

 
4. Click on the Printer Properties link or the Properties button.  
5. Click on Adobe PDF Settings tab if it is not on top 

 
6. Make sure Conversion Settings Default is set to Smallest File Size if you plan to 

distribute this file from the web or via email. Standard is an all-round good 
compromise choice. 
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7. Choose "Prompt for filename" if it is not already selected. Prompt for filename 
allows you to control the location as well as the name of the saved PDF file.  

8. Check "View Adobe PDF Results" if it is not already checked. This will open the 
PDF file in Acrobat as soon as it is created. 

9. Click on OK to close the settings dialog. 
10. Click on the Print or OK button to print.  
11. Since you have now changed your current printer, verify that your document still 

appears as you expect. Look at tables, images, and page breaks. Check the 
page numbers against your table of contents. Make sure you have no blank 
pages or missing page numbers. 

12. If you discover changes that need to be made, make them at this time while the 
Adobe PDF printer is still your current printer driver. Save your file again. If you 
made any changes, print again to create a new PDF file. 

Create a PDF File Using Word 2010 
File > Save As > select PDF from the drop down list for file type:

 

 
Click on the Options button. 

 
Click on OK after you modify your options. Click on Save. 
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Using PDFMaker Macro with MS Word 2010 
1. Click on the Acrobat tab 

 
2. Click on Preferences.  

 
3. Choose the appropriate conversion settings for your document’s intended use 

and uncheck any features that you don’t have in your document or anything that 
you don’t want converted to corresponding features in the PDF document.  

4. Set your Bookmark and Word tab preferences. 
5. Click on OK. 
6. To create the PDF file, click on the Acrobat tab   Create PDF 

or click on File and choose Save As Adobe PDF.  

Import an image file into Acrobat 
1. Start Adobe Acrobat Professional software. 
2. Go to File > Open 
3. Tell Acrobat to look for all files instead of just pdf files. 
4. Browse for and select the graphic file you want. JPEG files’ appearance might 

deteriorate after conversion with default options. 
5. Click on Open. 
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Enhance a PDF file 
Bookmarks 

Bookmarks allow you to supply additional navigation to your document. View 
the page where you wish to create a bookmark, establish the zoom level, and 
press Ctrl B or right click and choose Add Bookmark from the shortcut menu. 
Enter a title for the bookmark. If you select text ahead of time with the Text 
Select tool, that text will be used as the bookmark title. 

 

Hyperlinks 
You can add links to other files or locations to your document. Clicking on a hyperlink 
will take the reader to a different page in the same PDF file, a different PDF 
document, or to a web page. The Link tool is in the Content panel under the Tools 
Pane. 

Document Properties 
You can control how the document opens (initial view) and make sure that the 
document’s internal information (meta data such as author, title, keywords, etc.) 
matches what you want it to be. File > Properties 

Page Numbers 
You can make the Acrobat navigation page numbers match the numbering scheme 
used in your document.  
Tools pane > Document Processing > Number Pages 

Markup and Annotations 
Comment > Annotations: Sticky Note, Highlight, Attach File, Record Audio, Stamp 
Comment > Drawing Markups: Text Box, Callout, Pencil, Line, assorted shapes  

Multimedia 
Tools > Content > Multimedia: Insert a Video, a Sound file, a Flash file, or a 3D 
model. Adobe Reader versions 9 and X have a built-in Flash player. 

Optimize 
Go to the File menu and select Save As. Save the file with the same or a different 
name. This newly saved file is now "Optimized" for Fast Web View; this makes the 
file more easily viewed on the web, especially if the file is large (>4M). 

Security 
Go to the File menu and select Properties. Click on the Security tab. Select 
Password Security from the roll down list of security methods. Enter a password to 
change security settings. You can optionally password protect the document from 
being opened. You can disallow printing, selecting text, changing the file, and 
changing annotations. 
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Menus, Toolbars, and Panels 
Determine which tool panels are available by going to View > Tools.  

 

Right click on a toolbar at the top and select the tools you wish to appear in that toolbar 

File Menu 
Open | Create | Save | Attach to Email | Action Wizard | Close | Properties | Print | Exit 

Edit Menu 
Undo | Redo | Cut | Copy | Paste | Delete | Select All | Snapshot | Check Spelling | Find | Preferences 

View Menu 
Rotate View | Page Navigation | Page Display | Zoom | Tools | Comment | Share | Show/Hide … 

File Toolbar 

 
Open | Save | Print | Share | Get Doc Signed Online 
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Page Navigation Toolbar 

 
First Page | Previous Page | Next Page | Last Page | Page Number | Previous View | Next View 

Select and Zoom Toolbar 

 
 Select – select paragraphs for copying or for modifying text attributes 
 Hand – move document around on screen, fill out PDF forms on the web 
 Marquee Zoom  | Continuous Zoom 
 Zoom Out  |  Zoom In |  Select a percentage 
 Fit Width  |  Fit Page in window  

Tools Panels 
These are on the right. Click on the Show Tools Pane button in the upper right. 

 

Pages 

 

Content 

 

Document Processing 
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Navigation Panels 
Adobe Acrobat has a variety of navigation panels, each with a collapsible Navigation 
Pane along the left side of the program window.  If the navigation pane is minimized or 
closed, you can open it by clicking on any button in the vertical area on the left.   View 
 Show/Hide  Navigation Panes.  
You can use the Page Thumbnails navigation pane to display and rearrange pages in a 
thumbnail view.  Other navigation panes include: 
Bookmarks, Attachments, Signatures, Content, 
Order, Tags,  

When a navigation panel is open, you can see an 
Options button. Clicking on this button will bring 
up a menu of choices specific to the navigation 
pane that is currently active. 
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Adobe Reader Tools 
The figure below shows the menu, panels, and tools that those who view a copy of your 
PDF will have available by default when they open it in the free Adobe Reader.  

 
They can add a few more tools to this toolbar or delete tools they don’t want:  
View > Show/Hide > Toolbar Items.  

If they are viewing the PDF file in their web browser, the toolbar might look like: 

Tools include Print, Save, Attach to Email, Previous Page, Next Page, Select Text,  
Hand Tool, Marquee Zoom, Zoom in/out tools, Fit Width, Fit in Window, Find  

Zoom in and Zoom out 
Click on the plus sign (+) button to zoom in (increase magnification, text appears larger) 
Click on the minus sign (-) to zoom out (decrease magnification, text appears smaller) 
Use the Marquee Zoom tool to select an area of the PDF page to zoom in on. 
You can enter a magnification level or select one from the drop-down list (10% - 6400%) 

Navigation 
Click the Previous Page button to view the page preceding the one you're viewing. 
Click the Next Page button to see the next page in the document. 
If you have the magnification set to Fit in Window, you can use the Page Up and Page 
Down keys on your keyboard to move forward and back one page at a time. 
You can press Ctrl Home to go to the first page and Ctrl End to go the last page. 

Find tool 
Go to the Edit menu and select Find or press Ctrl F.  
Your cursor will move to the Find box on the toolbar. 
Enter text – each time you press the enter key, it will go to that text in the PDF file.  
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Bookmarks 
Bookmarks appear in the Navigation Pane along the left side of the document. Click on 
a bookmark title to go to the bookmarked view. A bookmark can be set to jump to 
another page within the document, open another PDF file, go to a web page, etc. 

Adding Bookmarks 
1. Click on the Bookmarks icon in the Navigation Panel.                
2. Go to the page where you want to set a bookmark. 
3. Verify the zoom level is what you want it to be 
4. Press Ctrl-B on your keyboard  

or right click on the PDF file and choose Add Bookmark 
5. Type new text over the untitled placeholder and press the 

enter key 
Tip:  if you select text in the PDF file with the Select tool before you press Ctrl-B, the 
selected text will appear as the bookmark title. 

6. Test your bookmark: switch to a different page in your document and then click on 
your bookmark title and verify that your view now displays the correct page. 

Editing Bookmarks 
1. Rearrange the order of the bookmarks by clicking on the tiny bookmarked page icon 

on the left of the bookmark title and dragging and dropping the icon to a new location 
between two other bookmarks.       

2. You can create subordinate bookmarks by dragging until the 
triangle and dotted line are between the tiny icon and bookmark title 
before releasing the mouse.   

3. Click on the - sign to close up a section of bookmarks;  
click on the + sign to expand a section of bookmarks.  

4. Edit a bookmark title: 
a. Select the bookmark. 
b. Click one on the text portion and the entire bookmark text is selected. You can 

type new text here to replace the entire existing bookmark title.  
c. Click once more and the cursor will appear on the line of text, 

allowing you to edit. 
5. Delete a bookmark 

a. Click once on a bookmark page icon to select it. 
b. Press the Delete key on the keyboard or click on the trashcan icon on the pane. 

Modify a bookmark’s properties:   
Right click on a bookmark’s page icon and select Properties from the shortcut menu.  
You can change the bookmark’s title appearance, its view zoom level, or its destination. 
To make bookmarks appear automatically when your document opens:  
File  Properties  Initial View tab.   
Under the list of navigation tab choices, select “Bookmarks Panel and Page.” Click OK. 
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Changing Text Attributes 
1. Click on:   

Tools  Content  Edit Document Text 
2. Highlight the text you want to change.  
3. Right click on the text. 
4. Select Properties from the shortcut menu. 
5. If you get a warning about the font, click on OK. 
6. You can change the font, its size, or its color. You can change the spacing 

between the characters or affect the word's vertical position on the line. 
7. You cannot add bold or italics unless there is a font choice with the desired style 

built in. You cannot add underlining – that has to be done in the original file 
before conversion. 

Change Text Content 
This is useful only for correcting a few errors you notice at the last minute. If you need to 
make substantial changes, you should edit the original file and create a new PDF file 
(you can choose to recreate one or more pages, then replace pages) 
1. Select the TouchUp Text tool: Tools  Content  Edit Document Text. 
2. Highlight the character(s) you wish to change and enter new character(s) to replace 

them. The text will not wrap but you can hit enter (be careful as you might get some 
unexpected results). You can cut, copy and paste text as usual.  
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Hyperlinks 
Hyperlinks can appear as a box within the document or they can be invisible.  However, 
a working hyperlink should be apparent when you hover the mouse over a link.   Simply 
click on the hyperlink to activate it. A hyperlink can be configured to jump to another 
page within the current document, another document, an e-mail address, a web site, 
etc. 

Adding Hyperlinks 
1. Click on the Link tool:  Tools  

Content  Link. 
2. Click on the page and drag to draw a 

box around the text or graphic that will 
become the link. 

3. Change the Link Appearance: 
a. If you want different color text, 

change the text attributes or 
change it in your original file before 
converting to PDF. 

b. Choose whether or not you want to 
see a rectangle surrounding the 
link in the PDF file and if so, the 
line color and thickness. 

c. Choose what the link will look like while the mouse is clicked down: Invert, Inset, 
Outline, or no difference. 

4. For Link Action, choose “Go to a page view” if you want the link to jump to another 
page. Click on Next.  

 
Go to the new location in the PDF file.  Click on Set Link. 

5. To create a link to a web page : 
a. Complete steps 1-3 above. 
b. Change the Link Action to Open a web page 
c. Type the complete URL including http:// into the Address box. Click on the down 

triangle to select a recently used URL. 
d. To set the link to an email address, type the full email address preceded by 

mailto:  (e.g. mailto:juser@mail.wvu.edu.) 

mailto:juser@mail.wvu.edu
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Modifying Document Pages 
Insert Pages 
1. Tools Pages   

Insert From File 
2. Select the file you want to insert. 
3. Acrobat will prompt you for the location 

to insert the file into the current 
document. 

4. Click on OK 
 

Delete Pages 
1. Go to the first page you wish to delete  
2. Tools  Pages  Delete 
3. The "Delete Pages" dialog window will 

specify the page number of the page you 
are viewing. Make the second number 
larger if you want to delete consecutive 
pages. Note that these are physical page numbers, not the ones printed on your 
document. 

4. Click on OK. 
 
 

Renumber Pages 
You can force the page numbers in the 
navigation tool at the bottom to match the 
ones on the pages. 

1. Tools Panel  Document 
Processing  Number Pages 

2. Specify the pages that should be 
renumbered. 

3. Choose a style 
4. Click on OK 

You can have the page numbers at the 
bottom of your front matter be numbered with 
roman numerals; then start a new section at 
the beginning of your body numbered with 
Arabic numerals, starting at 1 again. 
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Rotate Pages 
Sometimes you have a page that you need 
to rotate so your readers don’t have to tilt 
their heads to view it properly. 
1. View the page that needs to be rotated. 
2. Tools Pages  Rotate 
3. Choose direction: clockwise or counter-

clockwise 
4. Select the range of pages to be rotated 

and click on OK. 
 

Crop Pages 
1. View the page that needs to be cropped. 
2. Select the Crop tool from Tools > Pages and draw a box around the portion of 

the page you wish to keep. 
3. Double click inside the box. 
4. You can then fine tune your crop margins and select a range of pages. 

 
5. Click on OK. 
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Preferences 

Edit  Preferences 
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File  Properties  

 
 

Initial View tab 
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Security tab 

 
 

 
 



 

Ways to Learn More about Acrobat 
Following are some recommended web sites and books that you may find 
helpful for learning more about Acrobat: 

• Adobe's Web Site: [www.adobe.com/products/acrobat/] 

o Adobe Communities: www.adobe.com/communities/  

o Acrobat User Community: acrobatusers.com/  

• Lynda.com  (www.lynda.com/) – short-term loaner accounts available 
from the Office of Information Technology: 

Title Hrs:min Release Date 
Acrobat X Essential Training 08h 59m 11/2010 
Acrobat X Tips and Tricks  04h 33m 09/2011 

• PDFzone.com [www.pdfzone.com/ ] 

• Planet PDF Forum [forums.planetpdf.com/ ] 

• Adobe Acrobat X Classroom in a Book (includes CD with lesson files), 
Adobe Creative Team, Adobe Press 

• How to Do Everything: Adobe Acrobat X, Doug Sahlin, March 2011 

 

http://www.adobe.com/products/acrobat/
http://www.adobe.com/communities/
http://acrobatusers.com/
http://www.lynda.com/
http://www.lynda.com/Acrobat-training-tutorials/141-0.html
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